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Con v e c t i o n  Coo l i n g  o f  C i r c u i t  Boa r d s

This discussion models the air cooling of circuit boards populated with multiple 
integrated circuits (ICs), which act as heat sources. It provides two examples as 
depicted in Figure 2-1: vertically aligned boards using natural convection, and 
horizontal boards with forced convection (fan cooling). Convective contributions 
dominate the cooling. The convection is caused by the induced, or forced, flow of air. 
To achieve high accuracy, the simulation models heat transport in combination with 
the fluid flow. 

A
B

Natural convection cooling Forced convection cooling

Figure 0-1: Stacked circuit boards with multiple in-row heat sources. Line A represents the 
center line of the row of ICs, and the area between lines A-B on the board represents the 
symmetry.

A good technique is to describe convective heat flux with a film-resistance coefficient, 
h. The heat-transfer equations then become simple to solve. However, this 
simplification requires that the coefficient is well determined. For many systems and 
conditions suffer from a lack of detailed knowledge of h, making accurate calculations 
of convective heat transfer difficult to achieve. 

Instead of simplifying the equations, an alternate way to thoroughly describe the 
convective heat transfer is to model the heat transfer in combination with the fluid-flow 
field. The results then accurately describe the heat transport and temperature changes. 
From such simulations it is also possible to achieve accurate determinations of the film 
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4 |  C O N V E C T I
coefficients. These types of models are somewhat more complex but are useful for 
unusual geometries and complex systems such as circuit-board cooling.

The following examples model the heat transfer of a circuit-board assembly using two 
application modes: General Heat Transfer and Non-Isothermal Flow. The modeled 
scenario is based on work published by A. Ortega [1], and this discussion also 
compares model results with Ortega’s experimental results. The first example simulates 
natural convection cooling of a vertical circuit board, as depicted in Figure 2-1.

(a) (b)

Figure 0-2: The modeled 2D geometry (a), and 3D geometry (b).

In doing the modeling, it is a good idea to first set up a 2D model for the natural 
convection case. The geometry is the cross section, from the board backside to the next 
board backside, through the center of a row of ICs (that is, as indicated by line A in 
Figure 2-1). Next create a 3D model for the same case. Due to symmetry, it is 
sufficient to model a unit cell, from the backside of a board to the next backside, 
covering the area between lines A and B in Figure 2-1. Figure 2-2 depicts the two 
geometries for the natural convection case. 

The dimensions of the original geometry are: 

• Board: length (in the flow direction) 0.13 m, and the thickness is 0.002 m

• ICs: length and width are both 0.02 m, and thickness is 0.002 m

• The distance of air between the boards is 0.010 m

For the forced convection case, the 3D model is set up by rotating the geometry of 
Figure 2-2 (b), so that the boards are aligned horizontally.
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Model Definition
The model makes use of two stationary application modes to simulate the problem: 
General Heat Transfer, and Non-Isothermal Flow. 

The Non-Isothermal Flow case, modeled with the Navier-Stokes equations, describes 
the fluid velocity, u, and the pressure, p as:

∇ η ∇u ∇u( )T
+( )⋅– ρ u ∇⋅( )u ∇p+ + ρ ρ0–( )g=

∇ ρu( )⋅ 0=

Due to heating of the fluid, deviations occur in the local density, ρ, compared to the 
inlet density, ρ0. This results in a local buoyancy force expressed as (ρ-ρ0)g. The model 
also treats viscosity, η, as being temperature dependent. 

The General Heat Transfer application mode is based on a general energy balance

∇ k∇T–( )⋅ Q ρCPu ∇T⋅( )–=

where k represents thermal conductivity; Cp is the specific heat capacity; and Q is the 
heating power per unit volume, set to 1.25 MW/m3 (1 W/component) for the 3D 
cases. For the 2D cases, you should set it to 2/3 of that value to represent the lateral 
average heating power (that is, taking into account the open slots between the ICs). 
The material properties appear in Table 2-1.

TABLE 0-1:  MATERIAL PROPERTIES

MATERIAL PROPERTY HEAT SOURCE (SILICON) CIRCUIT- BOARD (FR4)[2]

ρ [kg/m3] 2330 1900

Cp [J/kg K] 703 1369

k [W/m K] 163 0.30

The model treats properties for air as being temperature dependent according to the 
following equations [3]: 

ρ p0Mw( ) RT( )⁄=

with p0 = 101.3 MPa; Mw = 0.0288 kg/mol; and R = 8.314 J/mol K.

Cp 1100ρ=

logk -3.723 + 0.865log T( )( )=
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η 6.0 6–×10 4.0 8–×10 T+=

We specify the boundary conditions for the flow inlet as boundary-normal flow with a 
known velocity field. For the natural convection models, set the inlet velocity to zero. 
For the forced convection cases, set up a parabolic velocity profile (similar to a fully 
developed laminar profile), uy, at the inlet as a function of umax, which equals 1 m/s. 
In terms of an equation it is:

uy s 1 s–( )4umax=

where s represents the normalized inlet width, a predefined parameter in FEMLAB 
that spans 0 to 1 along each boundary segment. At the outlet the models all use normal 
flow/zero pressure. In addition, they apply no-slip conditions at the surfaces of the 
board and the ICs. At the inlet boundary then fix the temperature to 300 degrees K 
(room temperature), and at the outlet the models use purely convective heat flux. You 
should also set the lateral boundaries periodic with respect to temperature, making the 
temperatures equal on both boundaries at every y value. Finally, the models apply 
continuity of temperature and heat flux at all interior boundaries.

Results and Discussion

N A T U R A L  C O N V E C T I O N

Figure 0-3: Results from the 2D-model in terms of temperature distribution. 
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The results of the 2D model, depicted in Figure 2-3, show that the temperature of the 
ICs (heat sources) increases considerably as you apply a heating load of 1 W/
component. Note that the temperature increase of the sources varies from 30 degrees 
K for the lowest IC up to almost 90 degrees, experienced by the top IC. This is a result 
of the thermal “footprint” of the heat sources below. Another interesting result is that 
the circuit board contributes a large amount of cooling power on its back side, 
although the thermal conductivity is quite small. This is apparent in the result plots as 
a temperature rise in the fluid at the right-hand boundary (that is, the back side of the 
next board in the stack).

The fluid flow in the 3D problem is a bit more complex to solve because of the 
increased number of mesh nodes necessary to resolve the flow and heat transport 
fields. The results, depicted in Figure 2-4, show that the temperature increase at the 
hottest spot of each component is approximately three degrees higher for the 3D case 
than for the 2D case. 

Figure 0-4: Temperature distribution for the 3D modeling results.

In addition, the temperature difference among the various ICs is smaller in the 3D 
model, which predicts a more uniform temperature rise of the ICs. The ICs have an 
operating temperature between 70 and 80 degrees K above ambient. This result is 
probably closer to reality compared to the 2D simulation because it also includes the 
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horizontal gaps between the ICs. The difference in temperature rise along the board’s 
height is mainly explained by the fluid-flow pattern.

Figure 2-5 plots the fluid velocity for both the 2D and 3D models. The maximum fluid 
velocity is slightly higher in the 3D case than in the 2D case. More importantly, the 
flow field behaves differently in the two cases. When comparing Figure 2-5 (a) and (b) 
note that the velocity fields are rather similar along the center line of the heat sources. 
However, there is a channeling effect from the horizontal gaps.

(a)

(b)

 

Figure 0-5: Fluid-velocity distribution for the 2D model (a) and the 3D model (b). 
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F O R C E D  C O N V E C T I O N — H O R I Z O N T A L  B O A R D S

This model includes a forced fluid inlet velocity that represents the situation when a 
fan cools the ICs. As shown in Figure 2-6, the temperature rise in the ICs is generally 
somewhat smaller, approximately 50 to 60 degrees, compared to the natural 
convection cases due to the higher average fluid velocity. In the forced convection case, 
the difference in temperature rise along the board is more pronounced than in natural 
convection. This means that the effect of a “thermal footprint” is stronger as the fluid 
velocity increases. 

Figure 0-6: Temperature distribution in the case of forced convection cooling of horizontal 
boards.

Another interesting result, which can be seen in Figure 2-7, is that the channeling 
effect of the gap causes a reduction in the fluid flow rate above the sources. The 
cooling of the ICs is therefore reduced somewhat, as compared to an ideal case with 
an even flow field.
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Figure 0-7: Velocity distribution for the case of forced convection.

From the simulation results you can also determine the effective convection 
heat-transfer film coefficient, h. Calculate it by integrating the heat flux across the fluid 
boundary of the source objects. Then divide that value with the temperature difference 
between that of the fluid at the surface and the inlet temperature. Put in terms of an 
equation, it is:

hi
1

Ω1
------- qidΩ1∫⎝ ⎠

⎛ ⎞ 1
Ω2
------- Ts,idΩ2∫ Tf,0–⎝ ⎠

⎛ ⎞ 1–
=

where Ω1 is the surface of the source, Ω2 is the fluid cross section, qi is the heat flux, 
while Tf,0 and Ts,i represent the inlet fluid temperature and the surface temperature of 
source i. Thus, the value of h varies between the rows of the sources due to “thermal 
footprints” from upstream heat sources.

In the case of forced convection, it is common to use the adiabatic film resistance, had. 
It is defined similar to h except it uses Tcup instead of Tf,0. Tcup is the cross-section 
average of the fluid temperature, Tf, upstream of each source, defined as follows:
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Tcup ρn u⋅( )Tf Ω2d( )∫⎝ ⎠
⎛ ⎞ ρn u⋅( ) Ω2d∫⎝ ⎠

⎛ ⎞ 1–
=

Figure 2-8 compares the calculated values of h and had for the convection cases with 
experimentally achieved values using similar geometries.

Figure 0-8: Comparison of experimentally measured film resistances, h, (asterisk, solid 
line) for natural convection[1] with those calculated from the 2D model (squares, 
dash-dot) and the 3D model (triangles, dashed line).

The deviation from the experimental values for the natural convection may stem from 
differences in the geometry (which is not fully defined in the publication [1]). 

In the forced-convection case you can compare the achieved results with experimental 
results by calculating the Nusselt number, Nu. It follows from:

NuL had L k⁄( )=

where L in this case is the length of the heat source (20 mm). The calculated Nusselt 
numbers for the 2D model decrease from 16 to 11 between rows 1 and 4. These values 
agree well with the experimentally measured ones for similar geometries, being in the 
range of 15 [1]. 
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A general conclusion you can draw from this example is that modeling can achieve 
accurate values of convective heat-transfer film coefficients, although the values do 
differ somewhat between the 2D and 3D models. In addition, the good agreement 
between experimental values and those from the models indicates the models’ high 
accuracy.
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Modeling Using the Graphical User Interface—2D Natural 
Convection
Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_nat_2D

M O D E L  N A V I G A T O R

1 Start FEMLAB.

2 On the New page of the Model Navigator, set Space dimension to 2D.

3 Click Multiphysics. Select the application mode Heat Transfer Module>General Heat 

Transfer, and click Add.

4 Select the application mode Heat Transfer Module>Non-Isothermal Flow, click Add, 
and click OK.

O P T I O N S  A N D  S E T T I N G S

1 Define the following constant expressions in Constants under the Options menu:

NAME EXPRESSION

q_source 2/3*1/(2e-3*20e-3^2)

T0 300

rho0_air 1.013e5*28.8e-3/(8.314*T0)
I O N  C O O L I N G  O F  C I R C U I T  B O A R D S



2 Click OK.

3 Define the following expressions in Expressions>Scalar expressions in the Options 

menu:

NAME EXPRESSION

k_air 10^(-3.723+0.865*log10(abs(T)))

rho_air 1.013e5*28.8e-3/(8.314*T)

Cp_air 1.1e3*rho_air

eta_air 6e-6+4e-8*T

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 Create rectangles according to the following table by using Specify Object>Rectangle 
in the Draw menu.

OBJECT WIDTH HEIGHT BASE X Y

R1 0.002 0.13 Corner 0 0

R2 0.01 0.13 Corner 0.002 0

R3 0.002 0.02 Corner 0.002 0.01

2 Click the Zoom Extents toolbar button.

3 With R3 selected click the Array toolbar button, type 0.03 in the y edit field in the 
Displacement area and type 4 in the y edit field in the Array size area. Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 In the Multiphysics menu, select the Non-Isothermal Flow application mode.

2 Open Subdomain Settings in the Physics menu.

3 Select subdomains 1 and 3–6. Click the Active in this domain check box to deactivate 
the Non-Isothermal Flow application mode in those subdomains.

4 Select subdomain 2 and enter the following expressions in the edit fields:

PARAMETER EXPRESSION

ρ rho_air

η eta_air

Fy 9.81*(rho0_air-rho_air)
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5 Click OK to close the Subdomain Settings dialog box.

6 In the Multiphysics menu, select the General Heat Transfer application mode. 

7 Open the Subdomain Settings dialog box and select all subdomains. On the Init page 
type T0 in the Temperature edit field.

8 Apply the following settings on the Conduction page.

SUBDOMAIN 1 2

k (isotropic) 0.3 k_air

ρ 1900 rho_air

Cp 1369 Cp_air

9 With subdomain 2 selected, click the Convection tab, click the Enable convective heat 

transfer check box, and type u and v in the edit fields for x-velocity and y-velocity.

10 On the Conduction page, select subdomains 3-6. Click the Load button, choose 
Silicon, and click OK. 

11 In the Q edit field, type q_source.

12 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Set the boundary conditions according to the following table. 

BOUNDARY 5 22

Boundary condition Temperature Convective flux

T0 T0

Radiation type None

3 Click OK.

4 In the Multiphysics menu, select Non-Isothermal Flow. Open the Boundary Settings 
dialog box. 

5 Select all boundaries and apply the No slip boundary condition.

6 Select boundaries 5 and 22, apply Normal flow>Pressure conditions with pressure 0.

7 Click OK.

8 Open the Periodic Boundary Conditions dialog box from the Physics>Periodic 

Conditions menu.
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9 On the Source page, select boundary 1 and type T in the Expression edit field, and 
press Enter.

10 Click the Destination tab, select boundary 27 by selecting the corresponding check 
box, and type T in the Expression edit field.

11 Click the Source Vertices tab, select boundaries 1 and 2 in the Vortex selection list and 
click the >> button.

12 Click the Destination Vertices tab and select and add vertices 21 and 22. Click OK.

M E S H  G E N E R A T I O N

1 Open the Mesh Parameters dialog box from the Mesh menu. On the Global page 
select Normal from the Predefined mesh sizes list.

2 On the Subdomain page, select subdomain 2 and type 1.5e-3 in the Maximum 

element size edit field. Click OK.

3 Click Initialize Mesh in the Mesh menu.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve button to calculate the solution.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 In order to create Figure 2-3 open the Plot Parameters dialog box from the 
Postprocessing menu.

2 On the Surface page select Temperature from the list of Predefined quantities in the 
Surface data area. Click OK.

3 To achieve Figure 2-5 (a) change the Surface data to Velocity field similar to above 
and click OK.

Modeling Using the Graphical User Interface—3D Natural 
Convection
Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_nat_3D

1 Repeat the steps from the 2D model regarding the Model Navigator and Options 
And Settings, however, select 3D in the Space dimension list.
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G E O M E T R Y  M O D E L I N G

1 Create blocks according to the following table by using Block in the Draw menu.

OBJECT LENGTH X LENGTH Y LENGTH Z BASE X BASE Y BASE Z

BLK1 0.015 0.002 0.13 0 0 0

BLK2 0.01 0.002 0.02 0 -0.002 0.01

BLK3 0.015 0.01 0.13 0 -0.01 0

2 Click the Zoom Extents toolbar button.

3 With BLK2 selected click the Array toolbar button, type 0.03 in the z edit field in the 
Displacement area and type 4 in the z edit field in the Array size area. Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 Open Subdomain Settings in the Physics menu.

2 Select subdomains 2 to 6. Click to clear the Active in this subdomain check box to 
deactivate the Non-Isothermal Flow application mode in those subdomains.

3 Select subdomain 1 and enter the following expressions in the edit fields:

PARAMETER EXPRESSION

ρ rho_air

η eta_air

Fz 9.81*(rho0_air-rho_air)

4 Click the Artificial Diffusion button, select Streamline diffusion, and click OK.

5 Click OK to close the Subdomain Settings dialog box.

6 In the Multiphysics menu, select the General Heat Transfer application mode. 

7 Open the Subdomain Settings dialog box and select all subdomains. Click the Init tab 
and type T0 in the Temperature edit field.

8 Apply the following settings on the Conduction page

SUBDOMAIN 1 6

k (isotropic) k_air 0.3

ρ rho_air 1900

Cp Cp_air 1369
I O N  C O O L I N G  O F  C I R C U I T  B O A R D S



9 With subdomain 1 selected, click the Convection tab, click Enable convective heat 

transfer and type u, v and w in the edit fields for x-, y- and z-velocity.

10 Click the Artificial Diffusion button, select Streamline diffusion, and click OK.

11 On the Conduction page, select subdomains 2-5. Click the Load button, choose 
Silicon and click OK. 

12 In the Q edit field, type q_source.

13 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 Open the Boundary Settings dialog box from the Physics menu.

2 Set the boundary conditions according to the following table. 

BOUNDARY 3 4

Boundary condition Temperature Convective flux

T0 T0

Radiation type None

3 Click OK.

4 In the Multiphysics menu select Non-Isothermal Flow. Open the Boundary Settings 
dialog box. 

5 Select all boundaries and apply the No slip boundary condition.

6 Select boundaries 3 and 4, apply the Normal flow/Pressure boundary condition with 
pressure 0.

7 Select boundaries 1 and 34, apply the Slip/Symmetry boundary condition.

8 Click OK.

9 Open the Periodic Boundary Conditions dialog from the Physics>Periodic Conditions 
menu.

10 On the Source page, select boundary 2 and type T in the Expression edit field, and 
press Enter.

11 Click the Destination tab, select boundary 29 by selecting the corresponding check 
box, and type T in the Expression field.

12 In the Source Vertices page select and add vertices 1, 2, 39, and 40, in the mentioned 
order, by selecting them and clicking the “>>” button.

13 In the Destination Vertices page select and add vertices 21, 22, 43, and 44, also in 
the mentioned order. Click OK.
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M E S H  G E N E R A T I O N

1 Open the Mesh Parameters dialog box from the Mesh menu. On the Global page 
select Coarser from the Predefined mesh sizes list.

2 On the Boundary page, select boundary 2, type 3e-3 in the Maximum element size 
edit field and type 2 in the Element growth rate edit field. 

3 On the Advanced page, type 0.5 in the edit field for x-direction scale factor. Click 
OK.

4 Click Initialize Mesh in the Mesh menu.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solve Parameters dialog box from the Solve menu.

2 Select the Stationary nonlinear solver and select Direct (UMFPACK) from the Linear 

system solver list.

3 Clear the Symmetric matrices check box.

4 Click OK.

5 Click Solve to compute the solution. The problem is rather large, because of the 
strong coupling between temperature and velocity and because of the dense mesh. 
To solve the problem approximately 500 MB of free memory is required on the 
computer. The solution is achieved in approximately 15 minutes (using a 1.5GHz 
Intel M Processor).

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 In order to create Figure 2-4 open the Plot Parameters dialog from the 
Postprocessing menu. 

2 In the General page clear Slice and select Boundary plot type.

3 In the Boundary page select Temperature from the list of Predefined quantities in the 
Surface data field. Click Apply.

4 To produce Figure 2-5 (b), enable Slice and disable Boundary plot types in the 
General page. 

5 Select Velocity field as data in the Slice page.

6 Type 1, 0 and 8 in the edit fields x, y, and z levels. Click OK.
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Modeling Using the Graphical User Interface—3D Forced 
Convection
Model Library path: Heat_Transfer_Module/
Electronics_and_Power_Systems/circuit_board_forced_3D

This model is achieved by modifying the previous model (circuit_board_nat_3D). 
Begin with loading, or building that model.

G E O M E T R Y  M O D E L I N G

1 Go to draw mode by clicking the Draw toolbar button. 

2 Select all objects and open the Rotate dialog box from Draw>Modify.

3 Enter -90 in the edit field for Rotation angle.

4 Enter 1, 0, and 0 in the x, y and z edit fields for Rotation axis direction vector. Click 
OK.

P H Y S I C S  S E T T I N G S

Boundary Settings
1 In the Multiphysics menu, select the General Heat Transfer application mode.

2 Open Boundary Settings in the Physics menu.

3 Set the boundary conditions according to the following table. 

BOUNDARY 5 29

Boundary condition Convective flux Temperature

T0 T0

Radiation type None

4 Click OK.

5 In the Multiphysics menu select Non-Isothermal Flow. Open the Boundary Settings 
dialog box. 

6 Select boundary 29 and apply the Inflow/Outflow velocity condition. 

7 Enter -4*(1e4)*(z)*(0.01-(z))*(z>0) in the edit field for y-velocity. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Open the Solver Manager dialog box from the Solve menu.

2 On the Init page, select Initial value expression in the Initial value area.

3 Go to the Solve For page, select the Non-Isothermal Flow application mode.
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4 Click Solve. The solution process takes approximately 7 minutes and requires 500 
MB memory.

5 When the solution has been achieved, click the Init page of the Solver Manager. Select 
Current Solution in the Initial value area.

6 Go to the Solve For page, select both application modes. 

7 Click Solve to calculate the final result. This process also takes approximately 7 
minutes.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 In order to create Figure 2-6 open the Plot Parameters dialog from the 
Postprocessing menu. 

2 In the General page, select the Slice plot type and clear the Boundary plot type.

3 In the Slice page, select Temperature from the list of Predefined quantities in the 
Surface data field. 

4 Type 1, 10, and 0 in the edit fields x, y, and z levels. Click Apply.

5 To produce Figure 2-7, select Velocity field as data in the Slice page.

6 Type 0 in the x levels edit field and click OK.

Create the plot shown in the Model Navigator and when the model is opened.

7 Open the Plot Parameters from the Postprocessing menu.

8 Deactivate Slice and Arrow and activate Boundary and Streamline on the General page.

9 Click on the Streamline page.

10 Select Specify start point coordinates in the Streamline start points area.

11 Enter linspace(1e-3,13e-3,13) in the x edit field.

12 Enter linspace(0.13,0.13,13) in the y edit field.

13 Enter linspace(1.3e-3,1.3e-3,13) in the z edit field.

14 Select Use expression to color streamlines in the Streamline color area.

15 Click on the Color Expression button to open the Streamline Color Expression dialog 
box.

16 Enter T-296 in the Expression field, click OK to close the dialog box.

17 Click on the Tube Radius button to open the Tube Radius Parameters dialog box.

18 Click on the Radius data check box and select Temperature gradient from the 
Predefined quantities list.
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19 Clear the Radius scale factor Auto checkbox and enter 0.5 as the Scale factor, click OK 
to close the dialog box.

20 Click the Advanced button to open the Advanced Streamline Parameters dialog box.

21 Enter 1000 in the Maximum number of integration steps edit field, click OK to close 
the dialog box.

22 Select Options>Suppress>Suppress Boundaries to open the Suppress Boundaries dialog 
box.

23 Select boundary 4, 5, 6, 7, 9, 29, and 35, click OK to close the dialog box.

24 Click the Postprocessing Mode toolbar button.

25 Click the Scene Light toolbar button.

26 Double click the Axis field in the status bar at the bottom of the FEMLAB window 
to disable the axis.
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